В последнее время в процессе работы все меньше времени удается уделять написанию статей в своем бложике. По большей части это связано с тем, что теперешний мой профиль заключается на 90% в работе с активным сетевым оборудованием Cisco Systems, а этому мне еще учится и учится - собственных наработок пока нет.
Так что теперь, по мере сил, буду писать о том что пишут другие, т.е. буду публиковать ссылки.
Интересный функционал обнаружился в ройтерах Cisco в статье TTCP (cisco), некий аналог IPERF (linux) - оказывается в роутерах есть генератор тестового трафика и некий его (трафика) приемник! Проверил на Cisco 2941-MWR - работает! Полностью заменить iperf не может, но жизнь явно будет облегчать :)
Вникаю в мозгодробительную тему мультихоуминга CE-роутеров в MPLS сетях, в часности с применением EIGRP на уровне PE-CE.
Для затравки рекомендую прочитать Multihomed MPLS VPN sites running EIGRP. После чего досканально вникнуть в EIGRP PE-CE Routing Protocol Overview, Configuration, and Verification - очень подробное руководство с очень подробными примерами! Себе даже в pdf копию напечатал :)
Берегите мозг, Коллеги! :)
Показаны сообщения с ярлыком cisco. Показать все сообщения
Показаны сообщения с ярлыком cisco. Показать все сообщения
12 мая 2011 г.
7 янв. 2011 г.
Проблемы при подключении по ssh между маршрутизаторами Cisco
Сегодня наткнулся на довольно странную и неоднозначную проблему.
При подключении по SSH с одного маршрутизатора Cisco на другой получал многообещающий ответ:
Причем подобное сообщение получал и при попытке обратного подключения.
Гугл навел на команду дебага:
Повторяю попытку подключения:
Далее поиск по фразе "SSH CLIENT0: protocol version exchange failure (code = 1)" дал понять что проблема может крыться в разнице используемых версий протокола SSH и/или первоначальном обмене ключами.
Выяснилось, что на одном из роутеров я забыл поменять версию протокола SSH на v2.
Смена версии также потребовала увеличения длинны ключа.
После перегенерации ключа длинной более 768 бит соединение устанавливается без проблем.
При подключении по SSH с одного маршрутизатора Cisco на другой получал многообещающий ответ:
c2811-01#ssh 172.16.11.76
[Connection to 172.16.11.76 aborted: error status 0]
Причем подобное сообщение получал и при попытке обратного подключения.
Гугл навел на команду дебага:
c2811-01##debug ip ssh client
SSH Client debugging is on
Повторяю попытку подключения:
c2811-01#ssh 172.16.11.76
[Connection to 172.16.11.76 aborted: error status 0]
c2811-01#
Jan 7 11:51:52.454 MSK: SSH CLIENT0: protocol version id is - SSH-1.5-Cisco-1.25
Jan 7 11:51:52.454 MSK: SSH CLIENT0: protocol version exchange failure (code = 1)
Jan 7 11:51:52.458 MSK: SSH CLIENT0: Session disconnected - error 0x00
Далее поиск по фразе "SSH CLIENT0: protocol version exchange failure (code = 1)" дал понять что проблема может крыться в разнице используемых версий протокола SSH и/или первоначальном обмене ключами.
Выяснилось, что на одном из роутеров я забыл поменять версию протокола SSH на v2.
Смена версии также потребовала увеличения длинны ключа.
После перегенерации ключа длинной более 768 бит соединение устанавливается без проблем.
10 нояб. 2010 г.
Расширение сознания через MPLS
До недавнего времни имел очень узкое представление о MPLS как о простой коммутации на основе меток.
На Opennet.ru нашелся замечательный сборник документации по MPLS на русском: http://www.opennet.ru/docs/RUS/mpls/
Читать следует с большой осторожностью, особенно новичкам - ломота в мозге и сны с "облаками" гарантированны.
Всем новичкам MPLS советую ознакомится.
На Opennet.ru нашелся замечательный сборник документации по MPLS на русском: http://www.opennet.ru/docs/RUS/mpls/
Читать следует с большой осторожностью, особенно новичкам - ломота в мозге и сны с "облаками" гарантированны.
Всем новичкам MPLS советую ознакомится.
9 авг. 2010 г.
8 авг. 2010 г.
Пишем анти-спуфинг ACL
Написано дабы самому не забыть и товарищам почитать.
Итак, задача укрепить защиту маршрутизатора напрямую подключенного в Интернет.
Первым делом защитимся от спуфинга - исключим из обработки (попросту отбросим) все пакеты идущие от серых (частных) сетей. Серые сети это сети предназначенные для частного использования и не маршрутизируемые в сети Интернет. Данные сети описаны в RFC1918, это префиксы 10/8, 172.16/12, 192.168/16.
В сети Интернет имеется еще несколько диапазонов адресов, появление которых на интерфейсе подключенном к сети интернет, в нормальных условиях будет по меньшей мере необычным. Данные сети описаны в RFC3330.
Следует понимать, что RFC3330 описывает сети специального назначения. Некоторые из этих сетей успели поменять свое назначение на "Reserved but subject to allocation", т.е. зарезервированы, но могут быть предоставленны в пользование. В общем случае такие сети блокировать не стоит, так как в случае передачи этих сетей в пользование, вы не сможете обмениваться с этой сетью данными.
Итак, составим список сетей которые мы будем блокировать на внешнем интерфейсе:
Также, тем кто получил собственный диапазон адресов, рекомендуется добавить собственную сеть в данный список на граничных маршрутизаторах.
На основе полученного списка сетей, составим ACL.
В данном случае я буду использовать extended acl, просто для возможности в будущем фильтровать еще и по адресу назначения.
У меня получился такой список доступа:
В данном списке доступа, кроме перечиленных выше префиксов, добавлено еще два хостовых адреса:
Также следует помнить, что на интерфейсах с настроенными туннелями IPSec, ACL повешенный на вход интерфейса проверяет сначала заголовок пакета IPSec, а затем этот же ACL проверяет заголовок шифрованного пакета. Таким образом упоминание в данном ACL частных сетей может нарушить функционирование туннеля.
После написания списка доступа, применяем его на вход на всех интерфейсах подключенных в сеть Интернет или в другие не безопасные сети:
Такая настройка внешних интерфейсов поможет избежать атаки с подделаных адресов.
Источники:
Итак, задача укрепить защиту маршрутизатора напрямую подключенного в Интернет.
Первым делом защитимся от спуфинга - исключим из обработки (попросту отбросим) все пакеты идущие от серых (частных) сетей. Серые сети это сети предназначенные для частного использования и не маршрутизируемые в сети Интернет. Данные сети описаны в RFC1918, это префиксы 10/8, 172.16/12, 192.168/16.
В сети Интернет имеется еще несколько диапазонов адресов, появление которых на интерфейсе подключенном к сети интернет, в нормальных условиях будет по меньшей мере необычным. Данные сети описаны в RFC3330.
Следует понимать, что RFC3330 описывает сети специального назначения. Некоторые из этих сетей успели поменять свое назначение на "Reserved but subject to allocation", т.е. зарезервированы, но могут быть предоставленны в пользование. В общем случае такие сети блокировать не стоит, так как в случае передачи этих сетей в пользование, вы не сможете обмениваться с этой сетью данными.
Итак, составим список сетей которые мы будем блокировать на внешнем интерфейсе:
- 10.0.0.0/8 - описана в RFC1918;
- 172.16.0.0/12 - описана в RFC1918;
- 192.168.0.0/16 - описана в RFC1918;
- 224.0.0.0/4 - RFC3330, Мультикастовые сети;
- 127.0.0.0/8 - RFC3330, Лупбэк сеть;
- 169.254.0.0/8 - RFC3330, RFC3927, Zeroconf адреса;
- 192.0.2.0/24 - RFC3330, Сеть для тестирования и использования в публикациях;
- 240.0.0.0/4 - RFC3330, Зарезервировано для будущего использования.
Также, тем кто получил собственный диапазон адресов, рекомендуется добавить собственную сеть в данный список на граничных маршрутизаторах.
На основе полученного списка сетей, составим ACL.
В данном случае я буду использовать extended acl, просто для возможности в будущем фильтровать еще и по адресу назначения.
У меня получился такой список доступа:
#sho ip access-list
Extended IP access list AntiSpoof
10 deny ip host 0.0.0.0 any
20 deny ip 10.0.0.0 0.255.255.255 any
30 deny ip 172.16.0.0 0.15.255.255 any
40 deny ip 192.168.0.0 0.0.255.255 any
50 deny ip host 255.255.255.255 any
60 deny ip 224.0.0.0 15.255.255.255 any
70 deny ip 127.0.0.0 0.255.255.255 any
80 deny ip 169.254.0.0 0.0.255.255 any
90 deny ip 192.0.2.0 0.0.0.255 any
100 deny ip 240.0.0.0 15.255.255.255 any
110 permit ip any any
В данном списке доступа, кроме перечиленных выше префиксов, добавлено еще два хостовых адреса:
- 0.0.0.0;
- 255.255.255.255;
Также следует помнить, что на интерфейсах с настроенными туннелями IPSec, ACL повешенный на вход интерфейса проверяет сначала заголовок пакета IPSec, а затем этот же ACL проверяет заголовок шифрованного пакета. Таким образом упоминание в данном ACL частных сетей может нарушить функционирование туннеля.
После написания списка доступа, применяем его на вход на всех интерфейсах подключенных в сеть Интернет или в другие не безопасные сети:
#conf t
#int f0/0
#ip access-group AntiSpoof
#end
Такая настройка внешних интерфейсов поможет избежать атаки с подделаных адресов.
Источники:
10 мая 2010 г.
L2TPv3 Ethernet Pseudowire
Отличная статья по настройке L2TPv3 Pseudowire на оборудовании Cisco: Configuring an L2TPv3 Ethernet Pseudowire
8 апр. 2010 г.
Вендел Одом про TSHOOT и его Beta
Вендел Одом опубликовал статью о сдаче TSHOOT, и отразил вней свое мение и найденые ошибки в бета-экзамене
6 апр. 2010 г.
STP/RSTP как они сходятся
Петр Лапухов на http://www.ine.com опубликовал обширный документ "Understanding STP and RSTP Convergence".
Всем готовящемся к сдаче BCMSN и всем кто администрирует сети использующие STP/RSTP.
Всем готовящемся к сдаче BCMSN и всем кто администрирует сети использующие STP/RSTP.
21 мар. 2010 г.
Шаблон базовой настройки маршрутизатора Cisco
На Хабре опуликована замечательная заметка Шаблон базовой настройки маршрутизатора Cisco.
9 мар. 2010 г.
Бродкаст-адрес в качестве ip helper-address
В больших сетях с развитой адресацией часто DHCP-сервер находится в другой, возможно очень отдаленной, подсети от клиента которому необходимы сетевые настройки.
И в таком случае администраторы на интерфейсе клиентского вилана прописывают ip helper-address - адрес на который пересылаются udp-бродскасты (по умолчанию это порты: 37, 42, 49, 53, 67, 68, 69, 137 и 138).
В таком случае если DHCP-сервер изменяет свой адрес (например, мигрировал на другой сервер) необходимо будет изменить на всех интерфейс-виланах ip helpter-address.
В свою очередь DHCP-сервер тоже находится в отдельной подсети, и эта подсеть имеет свой бродкастовый адрес. Допустим наш DHCP-сервер расположен в подсети 10.1.1.0, его адрес 10.1.1.1, маска подсети будет 255.255.255.248 и соответственно бродкастовый адрес подсети 10.1.1.7.
Конфигурация SVI вилана DHCP-серверов:
Логично предположить, что прописывая на SVI клиентского вилана не юникастовые, а бродкастовые ip helper-address можно дать себе возможность при необходимости добавлять/удалять сервера из пула (в нашем случае из сети 10.1.1.0/29) без перенастройки клиентских виланов.
Для примера возьмем клиентский вилан 100, в котором расположена сеть 10.1.2.0/24:
Однако данная конфигурация не работает.
На коммутаторах Cisco для обеспечения трансляции пакетов поступивших на бродкастовый адрес подсети извне этой сети, необходимо указать команду ip directed-broadcast. После чего коммутатор будет транслировать поступающие бродкасты в физические порты вилана.
Окончательная конфигурация серверного вилана выглядит следующим образом:
Ссылки:
IP Addressing and Services Commands
И в таком случае администраторы на интерфейсе клиентского вилана прописывают ip helper-address - адрес на который пересылаются udp-бродскасты (по умолчанию это порты: 37, 42, 49, 53, 67, 68, 69, 137 и 138).
В таком случае если DHCP-сервер изменяет свой адрес (например, мигрировал на другой сервер) необходимо будет изменить на всех интерфейс-виланах ip helpter-address.
В свою очередь DHCP-сервер тоже находится в отдельной подсети, и эта подсеть имеет свой бродкастовый адрес. Допустим наш DHCP-сервер расположен в подсети 10.1.1.0, его адрес 10.1.1.1, маска подсети будет 255.255.255.248 и соответственно бродкастовый адрес подсети 10.1.1.7.
Конфигурация SVI вилана DHCP-серверов:
int vlan 5
description DHCP_SERVERS
ip address 10.1.1.6 255.255.255.248
end
Логично предположить, что прописывая на SVI клиентского вилана не юникастовые, а бродкастовые ip helper-address можно дать себе возможность при необходимости добавлять/удалять сервера из пула (в нашем случае из сети 10.1.1.0/29) без перенастройки клиентских виланов.
Для примера возьмем клиентский вилан 100, в котором расположена сеть 10.1.2.0/24:
int vlan 100
ip address 10.1.2.1 255.255.255.0
ip helper-address 10.1.1.7
end
Однако данная конфигурация не работает.
На коммутаторах Cisco для обеспечения трансляции пакетов поступивших на бродкастовый адрес подсети извне этой сети, необходимо указать команду ip directed-broadcast. После чего коммутатор будет транслировать поступающие бродкасты в физические порты вилана.
Окончательная конфигурация серверного вилана выглядит следующим образом:
int vlan 5
description DHCP_SERVERS
ip address 10.1.1.6 255.255.255.248
ip directed-broadcast
end
Ссылки:
IP Addressing and Services Commands
6 мар. 2010 г.
Впечатления от сдачи экзамена Cisco TSHOOT Beta (643-832)
Вчера сдавал экзамен Cisco TSHOOT Beta (643-832).
Из положительного:
Из положительного:
- Новый GUI - понравилось что теперь время отсчитывается назад и ты всегда знаешь сколько осталось;
- всего 12 вопросов, остальное практические задания;
- Времени дали 3 часа
- Команды IOS попрежнему реализованы не все - например, очень не хватало "show int status";
- Практика решается в форме ответа на вопросы, конфигурацию изменять для проверки своей гопотезы нельзя - одно задание не смог решить, так как небыло нужного варианта ответа, потратил на него 45 минут;
- Есть опечатки как в топологии, так и в выводе команд - у меня один раз адреса выводились неправильные.
2 мар. 2010 г.
Превращаем Cisco Catalyst 6500 в кабельный тестер
Открыл для себя очень удобную фенечку 65ой каталисты - некоторые карты имеют встроенный "кабельный тестер" Time Domain Reflectometry (TDR)!
TDR может использоваться для определения обрывов в кабеле, неверно обжатых коннекторов, повреждений изоляции и др.
TDR поддерживается следующими медными линейными картами:
• WS-X6748-GE-TX (48 port CEF720 10/100/1000 line card)
• WS-X6548-GE-TX/45AF (48 port CEF256 10/100/1000 line card)
• WS-X6148A-GE-TX/45AF (48 port Classic 10/100/1000 line card)
• WS-X6148-GE-TX/45AF (48 port Classic 10/100/1000 line card)
• WS-X6148A-RJ-45/45AF (48 port Classic 10/100 line card)
Для тестирования кабеля необходимо выполнить две команды:
1. Первая - команда на тестирование порта:
2. Вторая - вывод данных тестирования:
в данном тесте обнаружено к-з на паре 7-8 .
Ссылки:
http://www.cisco.com/en/US/prod/collateral/switches/ps5718/ps708/prod_white_paper0900aecd805457cc.html
TDR может использоваться для определения обрывов в кабеле, неверно обжатых коннекторов, повреждений изоляции и др.
TDR поддерживается следующими медными линейными картами:
• WS-X6748-GE-TX (48 port CEF720 10/100/1000 line card)
• WS-X6548-GE-TX/45AF (48 port CEF256 10/100/1000 line card)
• WS-X6148A-GE-TX/45AF (48 port Classic 10/100/1000 line card)
• WS-X6148-GE-TX/45AF (48 port Classic 10/100/1000 line card)
• WS-X6148A-RJ-45/45AF (48 port Classic 10/100 line card)
Для тестирования кабеля необходимо выполнить две команды:
1. Первая - команда на тестирование порта:
6K-LV2-CL3# test cable-diagnostics tdr interface g1/3
TDR test started on interface Gi1/3
A TDR test can take a few seconds to run on an interface
Use 'show cable-diagnostics tdr' to read the TDR results.
2. Вторая - вывод данных тестирования:
6K-LV2-CL3# show cable-diagnostics tdr interface g1/3
TDR test last run on: March 5 10:22:06
Interface Speed Pair Cable length Distance to fault Channel Pair status
--------- ----- ---- ------------------- ------------------- ------- ------------
Gi1/3 1000 1-2 1 +/- 6 m N/A Pair B Terminated
3-4 1 +/- 6 m N/A Pair A Terminated
5-6 1 +/- 6 m N/A Pair C Terminated
7-8 1 +/- 2 m N/A Pair D Short
в данном тесте обнаружено к-з на паре 7-8 .
Ссылки:
http://www.cisco.com/en/US/prod/collateral/switches/ps5718/ps708/prod_white_paper0900aecd805457cc.html
8 февр. 2010 г.
Сертификационные экзамены в VUE
На Хабре опубликована заметка на тему "Оплата сертификационных тестов через VUE".
Для меня достаточно злободневная тема.
Отличное руководство для новичков сертификации! :)
Жаль только не сказано что можно сделать тестовому центру, который специально не публикует свое рассписание - заставляет переплачивать около 50% стоимости экзамена...
Для меня достаточно злободневная тема.
Отличное руководство для новичков сертификации! :)
Жаль только не сказано что можно сделать тестовому центру, который специально не публикует свое рассписание - заставляет переплачивать около 50% стоимости экзамена...
28 янв. 2010 г.
Voice-VLAN на Cisco Catalyst для Nortel IP Phone
Как удалось выяснить и опробовать сегодня на практике, Cisco Catalyst может передавать информацию о Voice-VLAN на IP-телефоны Nortel! :)
Для этого на коммутаторе достаточно включить протокол LLDP и прописать voice-vlan на порту телефона:
#conf t
#lldp run
#int fa1/0/1
#switchport voice-vlan 10
И конечно нужно чтобы на телефоне тоже был включен LLDP, указано тэгировать Voice-VLAN и конфигурировать его автоматически. Также на телефоне необходимо отключить тэгирование в Data-VLAN.
Тестирование проводилось на коммутаторе Catalyst 3750-24TS (IOS 12.2(46)) и телефонах Nortel 1110 и 1120.
Изрядно намучался с настройкой телефонов - русский перевод меню просто Ужасный!
Меню телефонов вообще неудобное, очень. Видимо нужно учится конфигурировать эти телефоны по сети.
Честно говоря, мне до последнего не верилось что Cisco включит передачу Voice-VLAN в реализацию LLDP. но я очень рад что компания пошла по пути унификации.
Ссылки:
Michael McNamara - LLDP with Cisco 3750
LLDP-MED and Cisco Discovery Protocol
Configuring LLDP and LLDP-MED
Для этого на коммутаторе достаточно включить протокол LLDP и прописать voice-vlan на порту телефона:
#conf t
#lldp run
#int fa1/0/1
#switchport voice-vlan 10
И конечно нужно чтобы на телефоне тоже был включен LLDP, указано тэгировать Voice-VLAN и конфигурировать его автоматически. Также на телефоне необходимо отключить тэгирование в Data-VLAN.
Тестирование проводилось на коммутаторе Catalyst 3750-24TS (IOS 12.2(46)) и телефонах Nortel 1110 и 1120.
Изрядно намучался с настройкой телефонов - русский перевод меню просто Ужасный!
Меню телефонов вообще неудобное, очень. Видимо нужно учится конфигурировать эти телефоны по сети.
Честно говоря, мне до последнего не верилось что Cisco включит передачу Voice-VLAN в реализацию LLDP. но я очень рад что компания пошла по пути унификации.
Ссылки:
Michael McNamara - LLDP with Cisco 3750
LLDP-MED and Cisco Discovery Protocol
Configuring LLDP and LLDP-MED
27 дек. 2009 г.
Оборудование Cisco: курс молодого бойца
Хочу порекомендовать всем начинающим Cisco-водам "Курс молодого бойца" Сергея Федорова.
Так же статью этого же автора на Хабре: http://habrahabr.ru/blogs/cisconetworks/69782/
Оба труда хорошо систематизированы, подходят не только для начинающего читателя и помогают систематизировать полученные ранее знания.
Так же статью этого же автора на Хабре: http://habrahabr.ru/blogs/cisconetworks/69782/
Оба труда хорошо систематизированы, подходят не только для начинающего читателя и помогают систематизировать полученные ранее знания.
Подписаться на:
Сообщения (Atom)
